Upgrading from 3.x to 4.x

From PGVWiki
Jump to: navigation, search


Use the following steps are required to upgrade from v3.x to v4.x. These steps assume that you are familiar with PhpGedView and have successfully installed it before.

Version 4.0 no longer includes support for index files. If you do not have PHP 5 with built-in SQLite support or a database account then you should not upgrade to PhpGedView 4.x. Maintenance releases will continue for the v3.3.x series.

Note to SQLite users: Unfortunately SQLite does not support the ALTER TABLE SQL command. This means that we must first drop the tables and recreate them. It is highly recommended that you run the backup before upgrading.

  1. Upload the new 4.0 files to your server replacing the old files with the new files. Do not replace the config.php file or the index directory.
  2. Go to upgrade33-40.php in your browser.
  3. SQLite users will need to reimport their GEDCOM files.
  4. You can now use your upgraded site. One change with this version splits user's full names into first and last name fields. If you have users who only entered a single name then their first and last name will be the same and it will appear doubled on some screens. You may want to review your user list and check your user's names.
  5. If you are using a customized theme you will need to update your theme with new stylesheets and variables. An excellent tool that can help you to merge themes is the WinMerge project http://winmerge.sourceforge.net/